El emulador de Windows Phone 8 no se inicia. Código de error 0x80131500

Tengo un problema con Visual Studio 2012 (SO: Windows 8.1 Preview)

  1. Crear proyecto vacío (aplicación de Windows Phone)
  2. Presione F5 para iniciar la depuración.

Y obtengo el código de error 0x80131500, sin una descripción detallada. Solo esto: Falló el despliegue de la aplicación al dispositivo.

Salida:

1>------ Deploy started: Project: PhoneApp1, Configuration: Debug Any CPU ------ 1>Deploying C:\Visual Studio 2012\Projects\PhoneApp1\PhoneApp1\Bin\Debu\PhoneApp2.xap... 1>Connecting to Emulator WVGA 512MB... 1>Deployment of application to device failed. 1>0x80131500 

¿Alguien ha encontrado tal problema? ¿Cómo se puede resolver?

Windows 8.1 Preview no es compatible con el Windows Phone 8 sdk para ejecutarse en Visual Studio 2012 . No puede ejecutar Emulator también, así que mejor debería usar una Windows 8 version estable de Windows 8 version para el desarrollo de WP8 . Esta es la statement del Microsoft Support

Después de actualizar su sistema operativo a Windows 8.1 Preview, no puede ejecutar el emulador del Kit de desarrollo de software (SDK) de Windows Phone 8 (XDE.exe) en Microsoft Visual Studio 2012

Referencia aqui

La instalación de Visual Studio 2012 Update 3 debería solucionar el problema http://support.microsoft.com/kb/2864215

En mi caso, la actualización de Windows Phone SDK y VS Express 2012 ayudó en Windows 8.1, pero el rendimiento es deficiente. Si es útil intente instalar la actualización en VS:

http://blogs.windows.com/windows_phone/b/wpdev/archive/2013/07/02/running-the-windows-phone-emulator-on-windows-8-1-preview.aspx

Y actualizando SDK:

http://dev.windowsphone.com/en-us/downloadsdk

Para alguien que está buscando una respuesta que tenga el mismo problema mientras trabaja en un entorno virtual, aquí hay un buen artículo sobre él.

Configuración: Visual Studio 2013 + Windows 8.1 (no betas) + esto funcionó
Resolución: reinicie el servicio Hyper-V

También estoy recibiendo este error al simular el progtwig. i hav win 8 only y vs12 windows phone …

pero cuando sigo info. con respecto a este error me sale no tengo la característica de ventanas hiper-v. Prueba esta característica que tienes o no y habilítala.

Enlace de Hyper-v: http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj863509(v=vs.105).aspx

Descubrí que esta es la clave a verificar, según los consejos para la resolución de problemas del emulador (WP8) (XDE) en msdn:

  1. Inicie el administrador de “Conexiones de red” (en la pantalla de inicio, escriba “Ver conexiones de red”, aparecerá en la lista de Configuración)

  2. Haga clic con el botón derecho en el adaptador denominado: “vEthernet (Interruptor interno del emulador de Windows Phone del puerto Ethernet interno)”

  3. Para ese adaptador, los únicos elementos que deben verificarse en “Esta conexión usa los siguientes elementos:” deberían ser:

    • Cliente para redes Microsoft
    • agendador de paquetes de QoS
    • Compartir impresoras y archivos para redes Microsoft
    • Controlador de protocolo LLDP de Microsoft
    • Controlador de E / S de Discovery Mapper Topology de Link-Layer
    • Respondedor de descubrimiento de topología de capa de enlace
    • Protocolo de Internet versión 6 (TCP / IPv6)
    • Protocolo de Internet versión 4 (TCP / IPv4)
  4. Todos los demás elementos deben estar desactivados.

Instalé Windows Phone 8 SDK. El emulador no funcionó porque Hyper-V no estaba encendido. Instalé Hyper-V desde Progtwigs y características y obtuve el error 0x80131500.

La actualización 4 de Visual Studio 2012 solucionó el problema.

Me enfrenté al mismo problema. Más tarde, pude solucionar el problema al descargar e instalar Visual Studio 2012 Update 4 desde el sitio web de Microsoft.

Pruebe estos pasos si usa VS 2012 con Windows 8.1 Pro:

  1. Desinstalar Hyper-V
  2. Reiniciar
  3. Instalar Hyper-V
  4. Reiniciar

Esto debería ayudar.

El servidor remoto de su servicio está deshabilitado. ¡Podrías habilitar el servidor remoto! Y no puede reinstalar Hyper-V. ¡Está funcionando para mí!

Resolví con la siguiente secuencia de reparación:

Desinstalar reinicio de Hyper-V

dism.exe / Online / Cleanup-image / Scanhealth
dism.exe / Online / Cleanup-image / Restorehealth

Reinicie Instalar Hyper-V

RG