Twitter Api 1.1. con .net 3.5

Estoy utilizando .net 3.5 framework. No puedo acceder a mi cuenta de Twitter desde mi sitio web desde que se modificó la API de Twitter. He buscado otras referencias alternativas para mi proyecto compatible con Api 1.1. Pero de ninguna manera, siempre me dijo “Está intentando instalar este paquete en un proyecto que apunta a ‘.NETFramework, Versión = v3.5’, pero el paquete no contiene referencias de ensamblajes ni archivos de contenido que sean compatibles con ese marco. ”

¿Alguien puede decirme alguna otra DLL compatible con Api 1.1 de Twitter y .net framework 3.5 para que pueda acceder nuevamente a mi cuenta de Twitter desde mi sitio web?

Muchas gracias.

Puedes usar TweetSharp v2.3.1. Es compatible con Twitter API 1.1 y también proporciona soporte completo para .NET Framework 3.5 (y también 2.0).

Puede obtenerlo a través de NuGet o GitHub : si usa NuGet Package Manager, puede instalarlo desde la ventana de comandos al hacer eso:

Install-Package TweetSharp 

Personalmente, puedo garantizar que funciona porque lo utilicé en un antiguo proyecto 3.5 y logré que funcionara.

NOTA IMPORTANTE : si su proyecto no incluye Newtonsoft Json.NET> = 5.0.6 (que es una dependencia requerida), NuGet intentará obtener una versión actualizada que podría darle problemas de compatibilidad con .NET 3.5. Si se encuentra con este problema, simplemente descargue Json.NET v5.0.6 manualmente , elimine todas las cosas descargadas por NuGet (incluido el archivo .refresh) y reemplácelas con los archivos dll de Json.NET que descargó (los que están en / Net35 / carpeta).